data binding problem

Topics: fixed
May 27, 2009 at 7:39 AM

Hi, I followed the sample in the source code, but found the data binding on the Textblock.Text in the ToolTip didn't work. Does the data binding support? or I made something wrong?

May 27, 2009 at 9:06 AM
Hi,

I'll check this out first and I'll provide you feedback on this mather.
Can you maybe send me the code (or a snippet of your code) to show me how you handle this?

This way I can investigate the issue closely to your needs.

Thanks!

Best regards,

Xavier Decoster

>----- Oorspronkelijk bericht -----
>Van
: jamesatcodeplex [mailto:notifications@codeplex.com]
>Verzonden
: woensdag
, mei
27, 2009 08:39 AM
>Aan
: xavier_decoster@telenet.be
>Onderwerp
: data binding problem [tooltipservice:57575]
>
>From: jamesatcodeplex
>
>Hi, I followed the sample in the source code, but found the data binding on the Textblock.Text in the ToolTip didn't work. Does the data binding support? or I made something wrong?
>
>
May 27, 2009 at 9:33 AM

I just bound the Text to a property of my viewmodel, other binding works except the TootTip, nothing special

<Button x:Name="GreenButton" Click="OnButtonClick" Grid.Column="1" Background="Green"
                Content="Green button" MouseEnter="OnButtonMouseEnter" MouseLeave="OnButtonMouseLeave">
            <Controls:ToolTipService.ToolTip>
                <Controls:ToolTip ShowDuration="10" InitialDelay="3" x:Name="greenTooltip">
                    <TextBlock Text="{Binding Message}"/>
                </Controls:ToolTip>
            </Controls:ToolTipService.ToolTip>
        </Button>

May 28, 2009 at 9:01 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
May 28, 2009 at 10:33 AM

thanks for informing me about this issue.

This issue should be fixed in release v1.3 which is available for download now.

 

Please let me know if you experience further issues.