Silverlight 3 version

Topics: fixed
Jul 24, 2009 at 2:15 PM

Hi,

Will you be releasing a SL3 version?

Thanks

jack

Coordinator
Jul 25, 2009 at 6:40 AM
Edited Jul 25, 2009 at 6:47 AM

Hi jack,

I'm currently working on an SL3 compiled version of the ToolTipService.

After testing, it should be available by the end of this weekend.

Anyway, Silverlight 3 is backwards-compatible, so it shouldn't be an issue to use this SL2 library, or just to recompile the source code against the SL3 runtime.

Best regards,

 

Xavier

Coordinator
Jul 25, 2009 at 6:52 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jul 26, 2009 at 5:53 PM

Xavier,

Thanks for the speedy release - it looks like the source_code zip is still the old version though.  I can't run it nor do I see any of the examples on using data context.

thanks

 

jack

Coordinator
Jul 27, 2009 at 6:32 AM

Hi Jack,

Notice that only the project files should be changed after the upgrade to SL3 (I didn’t change any code).

If you can’t run it, you might need to install the SL3 SDK (which you can find here: http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=2050E580-F1D5-4040-BB09-E6185591B6B5&displaylang=en).

Regarding the use of data context, it’s possible I commented it out in one of the collapsed regions of the Page.xaml.cs.

Anyway, I’ll take a look at this.

Thx for reporting!

Best regards,

Xavier

Jul 27, 2009 at 1:26 PM

Sorry I can run the test app from its page, I can run the dll in my application, but I cannot run the built solution.  I have the SDK, the rest of my application and 3rd party add-ons are SL3 as well.

Line: 53

Error: Unhandled Error in Silverlight 2 Application

Code: 2106   

Category: InitializeError      

Message: Failed to load the application. It was built with an obsolete version of Silverlight    

thanks.

From: XavierDecoster [mailto:notifications@codeplex.com]
Sent: July-27-09 12:33 AM
To: jaddington@alexandergracie.com
Subject: Re: Silverlight 3 version [tooltipservice:63444]

From: XavierDecoster

Hi Jack,

Notice that only the project files should be changed after the upgrade to SL3 (I didn’t change any code).

If you can’t run it, you might need to install the SL3 SDK (which you can find here: http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=2050E580-F1D5-4040-BB09-E6185591B6B5&displaylang=en).

Regarding the use of data context, it’s possible I commented it out in one of the collapsed regions of the Page.xaml.cs.

Anyway, I’ll take a look at this.

Thx for reporting!

Best regards,

Xavier

Read the full discussion online.

To add a post to this discussion, reply to this email (tooltipservice@discussions.codeplex.com)

To start a new discussion for this project, email tooltipservice@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jul 27, 2009 at 4:30 PM

I don't see anything commented out with respect to how to use the datacontext.  I would greatly appreciate it if you would post an example.  I am using the tooltip in an itemsControl, within the datatemplate.  I have an image that represents a status flag so I want to display a larger version of the icon plus some detailed text.

From: Jack Addington [mailto:jaddington@alexandergracie.com]
Sent: July-27-09 7:26 AM
To: 'tooltipservice@discussions.codeplex.com'
Subject: RE: Silverlight 3 version [tooltipservice:63444]

Sorry I can run the test app from its page, I can run the dll in my application, but I cannot run the built solution. I have the SDK, the rest of my application and 3rd party add-ons are SL3 as well.

Line: 53

Error: Unhandled Error in Silverlight 2 Application

Code: 2106

Category: InitializeError

Message: Failed to load the application. It was built with an obsolete version of Silverlight

thanks.

From: XavierDecoster [mailto:notifications@codeplex.com]
Sent: July-27-09 12:33 AM
To: jaddington@alexandergracie.com
Subject: Re: Silverlight 3 version [tooltipservice:63444]

From: XavierDecoster

Hi Jack,

Notice that only the project files should be changed after the upgrade to SL3 (I didn’t change any code).

If you can’t run it, you might need to install the SL3 SDK (which you can find here: http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=2050E580-F1D5-4040-BB09-E6185591B6B5&displaylang=en).

Regarding the use of data context, it’s possible I commented it out in one of the collapsed regions of the Page.xaml.cs.

Anyway, I’ll take a look at this.

Thx for reporting!

Best regards,

Xavier

Read the full discussion online.

To add a post to this discussion, reply to this email (tooltipservice@discussions.codeplex.com)

To start a new discussion for this project, email tooltipservice@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jul 27, 2009 at 4:56 PM

BTW - the AssemblyInfo still indicates version 1.2

I also can't find datacontext anywhere in the project?  I'm wondering if there is a mixup in the source code that is uploaded?  Otherwise I'm totally out to lunch..

thanks

jack

Coordinator
Jul 27, 2009 at 5:59 PM

Regarding to the assembly info, my mistake and my apologies :-) Forgot to change the version number.

I'll work out a demo for the data context as soon as I can.

The line 53 error appears very strange to me, but I'll check it on my other computer just to make sure.

Might be a local machine issue (specific configuration of my development machine).

Fix is coming up.

I'll keep you posted!

Thx for the detailed information, it's a great help.

Regards,

Xavier

Coordinator
Jul 27, 2009 at 6:00 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Jul 27, 2009 at 6:02 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Jul 27, 2009 at 6:23 PM
Ok, found the problem. I was not aware that the installed SDK version of Silverlight 3 was still the beta version.

Happens when time constrainst take it over from common sense :-)

 

jaddington wrote:

Sorry I can run the test app from its page, I can run the dll in my application, but I cannot run the built solution.  I have the SDK, the rest of my application and 3rd party add-ons are SL3 as well.

 

Line: 53

Error: Unhandled Error in Silverlight 2 Application

Code: 2106   

Category: InitializeError      

Message: Failed to load the application. It was built with an obsolete version of Silverlight    

 

thanks.

 

From: XavierDecoster [mailto:notifications@codeplex.com]
Sent: July-27-09 12:33 AM
To: jaddington@alexandergracie.com
Subject: Re: Silverlight 3 version [tooltipservice:63444]

 

From: XavierDecoster

Hi Jack,

Notice that only the project files should be changed after the upgrade to SL3 (I didn’t change any code).

If you can’t run it, you might need to install the SL3 SDK (which you can find here: http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=2050E580-F1D5-4040-BB09-E6185591B6B5&displaylang=en).

Regarding the use of data context, it’s possible I commented it out in one of the collapsed regions of the Page.xaml.cs.

Anyway, I’ll take a look at this.

Thx for reporting!

Best regards,

Xavier

Read the full discussion online.

To add a post to this discussion, reply to this email (tooltipservice@discussions.codeplex.com)

To start a new discussion for this project, email tooltipservice@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com